Flutter project running error Failed to find Build Tools revision 29.0.2

In the previous article, Flutter developed Android Studio to install a third-party emulator - Netease MuMu , which introduced the method of installing a third-party emulator, but after running the flutter run -d "MuMu" command, an error was reported, and I crashed again 😂. I finally installed an emulator, but it didn't work. My young mind was hurt again😭.

Calm down, let's calm down and look at the problem:👇

Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
> Failed to find Build Tools revision 29.0.2  

 Judging from the error message, it means that

Could not determine dependencies for task ':app:compileDebugJavaWithJavac', could not find Build Tools version 29.0.2

Looking around on the Internet, I also found that many friends have encountered similar problems. After some attempts, the problem was finally solved, and the solution process is as follows.

Find app->build.gradle->android in the project process of flutter

On the next line of compileSdkVersion, add the line buildToolsVersion "version number"

The version number is found in SDkTools in the Android SDK, and there is a version number in it, as shown below

 

After operating according to the above method, let's run the flutter project again to see

The first successful run will tell us some commonly used hotkeys

Flutter run key commands.

  • r Hot reload. 🔥🔥🔥
  • R Hot restart.
  • h Repeat this help message.
  • d Detach (terminate "flutter run" but leave application running).
  • c Clear the screen
  • q Quit (terminate the application on the device).

💪 Running with sound null safety 💪

rHot refill. 🔥🔥🔥

R warm restart.

hRepeat this help message.

d detach (terminate "flutter run", but keep the app running)

cClear the screen

q quit (terminate the app on the device)

Haha 😁, works perfectly, who else. . . . ? Looking up at the ceiling 45 degrees 🤩, my damn charm, nowhere to put it! 😁😎😎😁

 

 🌹Welcome everyone to leave a message to exchange, criticize and correct, learn from each other😁, improve yourself🌹

 

 

 

 

 

 

 

 

Related: Flutter project running error Failed to find Build Tools revision 29.0.2