Successfully solved the installation error under anaconda: PackagesNotFoundError: The following packages are not available from current chann

Solve the error when installing packages under anaconda : PackagesNotFoundError: The following packages are not available from current channels

Take the installation of the icecream package as an example

enterconda install icecreamWhen installing, an explicit error is reported.
insert image description here

Then we query the existing version of the package and enter the following command:

anaconda search -t conda icecream
  • 1

Then there will be a lot of confidence, choose the installation package you need
insert image description here

Select the version of the package you want to install according to your needs, and enter the following command to view the installation channel

anaconda show conda-forge/icecream
  • 1

insert image description here

Install according to the prompt command

conda install --channel https://conda.anaconda.org/conda-forge icecream
  • 1

Tags: Successfully solved the installation error under anaconda: PackagesNotFoundError: The following packages are not available from current chann

Topics in Python python

Related: Successfully solved the installation error under anaconda: PackagesNotFoundError: The following packages are not available from current chann